I have been bouncing between the RadRails and NetBeans IDEs for quite some time now. I like them both a lot, but I have not been able to make RadRails Test::Unit work 100% with Ruby 1.9.x. The 1.8.x version works fine, and I know there are some changes between the two Rubys that affect testing, but I have not done a complete analysis of the changes. In any event, I have switched to NetBeans 6.5.1 simply because I can run my Rails test suites with Ruby 1.9 and everything works.

Of course the real solution is to get my professional and financial houses in order, acquire a MacBook Pro running Snow Leopard and develop from TextMate or maybe RubyMine. But for now, I can endorse either RadRails or NetBeans as a pretty reasonable Rails development environment. Try out both, and choose your favorite.